CCNP Route - EIGRP Lab: Propagate default route

In EIGRP default routes cannot be directly injected (as they can in OSPF with the default-information originate command).

EIGRP does not redistribute the ip route 0.0.0.0 0.0.0.0 default route by default.

EIGRP will propagate default route:
1) redistribute static (in router eigrp) +
"ip route 0.0.0.0 0.0.0.0 200.0.0.2" OR
"ip route 0.0.0.0 0.0.0.0 Null0" (
OR exit interface)
2) network 0.0.0.0    
(in router eigrp) + "ip route 0.0.0.0 0.0.0.0 Null0" is set to exit interface (and not next_hop_IP
)

3) 'ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5' on interface facing Internal network (not ISP)
4) 'ip default-network 172.16.1.0' (
This method comes from IGRP): network must be classfull (A/B/C), network must not be directly connected to the advertising router (must be learned) 

GNS Lab
GNS3 topology file - https://db.tt/6Ty9uqXv

ISP Config
!
interface Loopback8
 ip address 8.8.8.8 255.255.255.0
!
interface Ethernet1/0
 ip address 200.0.0.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 200.0.0.1
Router BORDER, R3, R4  EIGRP config
!
router eigrp 99
 network 10.10.10.0 0.0.0.255
 auto-summary
!

Propagate default
1) redistribute static (in router eigrp) + "ip route 0.0.0.0 0.0.0.0 200.0.0.2" OR "ip route 0.0.0.0 0.0.0.0 Null0" (OR exit interface)

Null0 case - will propagate default route, but BORDER will not routes any destinations except in RIB
BORDER
!
router eigrp 99
 redistribute static
 network 10.10.10.0 0.0.0.255
 auto-summary
!
ip route 0.0.0.0 0.0.0.0 Null0
!
BORDER#sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "static", distance 1, metric 0 (connected), candidate default path
  Redistributing via eigrp 99
  Advertised by eigrp 99
  Routing Descriptor Blocks:
  * directly connected, via Null0
      Route metric is 0, traffic share count is 1
BORDER#
R3#sh ip route | be Gateway
Gateway of last resort is 10.10.10.1 to network 0.0.0.0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
D*EX 0.0.0.0/0 [170/28160] via 10.10.10.1, 00:02:49, FastEthernet0/0
R3#traceroute 8.8.8.8
Type escape sequence to abort.
Tracing the route to 8.8.8.8
  1 10.10.10.1 4 msec 20 msec 20 msec
  2 10.10.10.1 !H  !H  !H
R3#
ISP next hop case - "Normal" default, where packets reach destinations beyond own AS
BORDER
!
router eigrp 99
 redistribute static
!
ip route 0.0.0.0 0.0.0.0 200.0.0.2
!
R3#clear ip route *
R3#sh ip route | be Gateway
Gateway of last resort is 10.10.10.1 to network 0.0.0.0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
D*EX 0.0.0.0/0 [170/284160] via 10.10.10.1, 00:00:01, FastEthernet0/0
R3#traceroute 8.8.8.8
Type escape sequence to abort.
Tracing the route to 8.8.8.8
  1 10.10.10.1 40 msec 20 msec 20 msec
  2 200.0.0.2 52 msec 24 msec 60 msec
R3#

2) network 0.0.0.0     (in router eigrp) + "ip route 0.0.0.0 0.0.0.0 Null0" is set to exit interface (and not next_hop_IP)
BORDER
!
router eigrp 99
 network 10.10.10.0 0.0.0.255
 network 0.0.0.0
 auto-summary
 no redistribute static
!
no ip route 0.0.0.0 0.0.0.0 200.0.0.2
ip route 0.0.0.0 0.0.0.0  e1/0
!
R3#sh ip route | be Gateway
Gateway of last resort is 10.10.10.1 to network 0.0.0.0
D    200.0.0.0/24 [90/284160] via 10.10.10.1, 00:05:56, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
D*   0.0.0.0/0 [90/28160] via 10.10.10.1, 00:00:06, FastEthernet0/0
R3#traceroute 8.8.8.8
Type escape sequence to abort.
Tracing the route to 8.8.8.8
  1 10.10.10.1 36 msec 16 msec 16 msec
  2 200.0.0.2 88 msec 28 msec 40 msec
R3#

3) 'ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5' on interface facing Internal network (not ISP)
BORDER
!
router eigrp 99
 network 10.10.10.0 0.0.0.255
 auto-summary
!
no ip route 0.0.0.0 0.0.0.0  e1/0
!
!
BORDER(config)# interface FastEthernet0/0
BORDER(config-if)# ip summary-address eigrp 99 0.0.0.0 0.0.0.0
*May 11 01:05:55.667: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 99: Neighbor 10.10.10.3 (FastEthernet0/0) is resync: summary configured
*May 11 01:05:55.667: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 99: Neighbor 10.10.10.4 (FastEthernet0/0) is resync: summary configured

BORDER#sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "eigrp 99", distance 5, metric 28160, candidate default path, type internal
  Redistributing via eigrp 99
  Routing Descriptor Blocks:
  * directly connected, via Null0
      Route metric is 28160, traffic share count is 1
      Total delay is 100 microseconds, minimum bandwidth is 100000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 0
BORDER#
R3# sh ip route | be Gateway
Gateway of last resort is 10.10.10.1 to network 0.0.0.0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
D*   0.0.0.0/0 [90/30720] via 10.10.10.1, 00:01:21, FastEthernet0/0
R3#
R3# traceroute 8.8.8.8
Type escape sequence to abort.
Tracing the route to 8.8.8.8
  1 10.10.10.1 28 msec 20 msec 16 msec
  2 10.10.10.1 !H  !H  !H
R3#

4) 'ip default-network 172.16.1.0' (This method comes from IGRP): network must be classfull (A/B/C), network must not be directly connected to the advertising router (must be learned)
default-network         Flags networks as candidates for default routes
BORDER(config)#ip default-network ?
  A.B.C.D  IP address of default network


2 cases:

- EEIGRP default (auto-summary enabled)
- EIGRP no auto-summary
 

EIGRP Auto-summary enabled
BORDER
! The network advertised as the gateway of last resort must not be directly connected to the advertising router (must be learned)
! The network (network-number) must be reachable by the router that uses this command before it announces it as a candidate default route to other EIGRP routers.
! The network must either be an EIGRP-derived network in the routing table, or be generated with a static route and redistributed into EIGRP.
BORDER(config)# ip default-network 200.0.0.0
BORDER(config)# ip route 200.0.0.0 255.0.0.0 200.0.0.2
!
router eigrp 99
 network 10.10.10.0 0.0.0.255
 auto-summary
 redistribute static
!
BORDER#sh ip route | be Gatewa
Gateway of last resort is 200.0.0.2 to network 200.0.0.0
C*   200.0.0.0/24 is directly connected, Ethernet1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
S*   200.0.0.0/8 [1/0] via 200.0.0.2
BORDER#sh ip route 8.8.8.8
% Network not in table
BORDER#
BORDER#sh ip cef | exc drop|Fast
Prefix               Next Hop             Interface
0.0.0.0/0            200.0.0.2            Ethernet1/0   ???
0.0.0.0/32           receive
200.0.0.0/8          200.0.0.2            Ethernet1/0
200.0.0.0/24         attached             Ethernet1/0
200.0.0.0/32         receive              Ethernet1/0
200.0.0.1/32         receive              Ethernet1/0
200.0.0.2/32         attached             Ethernet1/0
200.0.0.255/32       receive              Ethernet1/0
224.0.0.0/24         receive
255.255.255.255/32   receive
BORDER#
R3# sh ip route | be Gateway
Gateway of last resort is 10.10.10.1 to network 200.0.0.0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
D*EX 200.0.0.0/8 [170/284160] via 10.10.10.1, 00:01:14, FastEthernet0/0
R3# traceroute 8.8.8.8 num
Type escape sequence to abort.
Tracing the route to 8.8.8.8
  1 10.10.10.1 28 msec 20 msec 20 msec
  2 200.0.0.2 20 msec 40 msec 40 msec
R3#
EIGRP Auto-summary disabled
Border
!
router eigrp 99
 redistribute static
 network 10.10.10.0 0.0.0.255
 network 200.0.0.0
 no auto-summary
!
ip default-network 200.1.0.0
ip default-network 200.1.2.0
!
ip route 200.1.0.0 255.255.0.0 200.1.1.2
ip route 200.1.2.0 255.255.255.240 200.1.1.2
!
BORDER#sh ip route | be Gat
Gateway of last resort is 200.1.1.2 to network 200.1.2.0
C    200.1.1.0/24 is directly connected, Ethernet1/0
     200.1.2.0/28 is subnetted, 1 subnets
S*      200.1.2.0 [1/0] via 200.1.1.2

     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
S*   200.1.0.0/16 [1/0] via 200.1.1.2
BORDER#




R4#sh ip route | b Ga
Gateway of last resort is 10.10.10.1 to network 200.1.2.0
     200.1.2.0/28 is subnetted, 1 subnets
D*EX    200.1.2.0 [170/284160] via 10.10.10.1, 00:01:36, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
D*EX 200.1.0.0/16 [170/284160] via 10.10.10.1, 00:13:58, FastEthernet0/0
R4#