CCNP ROUTE - EIGRP Frame Relay LAB part 1


Intro
Platform is based on Cisco IOU Web Interface over ESXi
http://www.routereflector.com/en/cisco/cisco-iou-web-interface/
http://evilrouters.net/2011/01/18/cisco-iou-faq/

Install instructions (russian)  http://habrahabr.ru/post/196228/

The Lab is based on GNS3 lab from
http://www.gns3-labs.com/2010/03/18/gns3-lab-excercise-ccna-ccnp-route-eigrp-lab/

The same LAB is available with Cisco IOU Web Interface.

Unetlab topology:
 - download
 - iol image="L3-ADVENTERPRISEK9-M-15.4-1T.bin"
 - iol image="L2-UPK9-M-june20-2012.bin"
 - config from topology presented below

Topology 
- 2 Core routers
- 2 Wan routers (Wan/core a linked through a switch)
- 3 Branch routers, each having a Frame-Relay PVC to each Wan Router.

CCNP EIGRP LAB TOPOLOY
 EIGRP Topics covered:
- Basic EIGRP config
- Dynamic Neighborship
- Auto-summary issues
- Split-horizon
- Neighborship settings (hello-timer, hold-timer eigrip RID)
- Static neighborship
- EIGRP authentication
- Passive interface
- Interface bandwidth over frame-relay
- EIGRP bandwidth usage
- Stub routers
- Offset-list
- Variance
- Default-route/network
- EIGRP Summarization
- Route filtering (prefix-list / route-map)

Initial configs

Frame Relay Router
hostname FRSW
frame-relay switching
!
interface Serial0/0
 description to WAN1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay intf-type dce
 frame-relay route 101 interface Serial0/2 101
 frame-relay route 102 interface Serial0/3 102
 frame-relay route 103 interface Serial1/0 103
!
interface Serial0/1
 description to WAN2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/2 201
 frame-relay route 202 interface Serial0/3 202
 frame-relay route 203 interface Serial1/0 203
!
interface Serial0/2
 description to BRANCH-1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay intf-type dce
 frame-relay route 101 interface Serial0/0 101
 frame-relay route 201 interface Serial0/1 201
!
interface Serial0/3
 description to BRANCH-2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/0 102
 frame-relay route 202 interface Serial0/1 202
!
interface Serial1/0
 description to BRANCH-3
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay intf-type dce
 frame-relay route 103 interface Serial0/0 103
 frame-relay route 203 interface Serial0/1 203
!
line con 0
exec-timeout 120 0
!

Branch1
hostname BRANCH-1
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 2016000
!
interface Serial1/0.1 point-to-point
 ip address 193.10.25.10 255.255.255.0
 frame-relay interface-dlci 101
!
interface Serial1/0.2 point-to-point
 ip address 193.10.26.10 255.255.255.0
 frame-relay interface-dlci 201
!
line con 0
exec-timeout 120 0
!

Branch2
hostname BRANCH-2
!
interface Loopback0
 ip address 10.1.2.1 255.255.255.0
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 2016000
!
interface Serial1/0.1 point-to-point
 ip address 193.10.25.20 255.255.255.0
 frame-relay interface-dlci 102
!
interface Serial1/0.2 point-to-point
 ip address 193.10.26.20 255.255.255.0
 frame-relay interface-dlci 202
!
line con 0
exec-timeout 120 0
!

Branch3
hostname BRANCH-3
!
interface Loopback0
 ip address 10.1.3.1 255.255.255.0
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 2016000
!
interface Serial1/0.1 point-to-point
 ip address 193.10.24.2 255.255.255.252
 frame-relay interface-dlci 103
!
interface Serial1/0.2 point-to-point
 ip address 193.10.24.6 255.255.255.252
 frame-relay interface-dlci 203
!
line con 0
exec-timeout 120 0
!

WAN1
hostname WAN1
!
interface Serial1/0
 description to FRSW
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 2016000
 frame-relay lmi-type cisco
!
interface Serial1/0.1 multipoint
 ip address 193.10.25.1 255.255.255.0
 frame-relay interface-dlci 101
 frame-relay interface-dlci 102
!
interface Serial1/0.2 point-to-point
 ip address 193.10.24.1 255.255.255.252
 frame-relay interface-dlci 103
!
interface Ethernet0/0
 ip address 10.0.0.10 255.255.255.0
no sh
!
line con 0
exec-timeout 120 0
!

WAN2
hostname WAN2
!
interface Ethernet0/0
 ip address 10.0.0.20 255.255.255.0
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 2016000
!
interface Serial1/0.1 multipoint
 ip address 193.10.26.1 255.255.255.0
 frame-relay interface-dlci 201
 frame-relay interface-dlci 202
!
interface Serial1/0.2 point-to-point
 ip address 193.10.24.5 255.255.255.252
 frame-relay interface-dlci 203
!
interface Ethernet0/0
 ip address 10.0.0.20 255.255.255.0
no sh
!
line con 0
exec-timeout 120 0
!

CORE1
hostname Core1
!
interface Ethernet0/0
 ip address 10.0.0.1 255.255.255.0
!
line con 0
exec-timeout 120 0
!

CORE2
hostname Core2
!
interface Ethernet0/0
 ip address 10.0.0.2 255.255.255.0
!
line con 0
exec-timeout 120 0
!

LAB Tasks
1) Configure EIGRP asn 15 on all routers and activate it dynamically on all interfaces using the corresponding subnet and wildcad-mask
Core1(config)#router eigrp 15
Core1(config-router)#network 10.0.0.0 0.0.0.255

Core2(config)#router eigrp 15
Core2(config-router)#network 10.0.0.0 0.0.0.255
*Nov  5 11:28:34.743: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 10.0.0.1 (Ethernet0/0) is up: new adjacency

WAN1(config)#router eigrp 15
WAN1(config-router)#network 193.10.25.0 0.0.0.255
WAN1(config-router)#network 193.10.24.0 0.0.0.3
WAN1(config-router)#network 10.0.0.0 0.0.0.255
*Nov  5 11:47:15.221: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 10.0.0.1 (Ethernet0/0) is up: new adjacency
*Nov  5 11:47:15.222: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 10.0.0.20 (Ethernet0/0) is up: new adjacency
*Nov  5 11:47:15.222: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 10.0.0.2 (Ethernet0/0) is up: new adjacency

WAN2(config)#router eigrp 15
WAN2(config-router)#network 10.0.0.0 0.0.0.255
*Nov  5 11:29:49.590: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 10.0.0.1 (Ethernet0/0) is up: new adjacency
*Nov  5 11:29:49.590: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 10.0.0.2 (Ethernet0/0) is up: new adjacency
WAN2(config-router)#network 193.10.26.0 0.0.0.255
WAN2(config-router)#network 193.10.24.4 0.0.0.3

BRANCH-1(config)#router eigrp 15
BRANCH-2(config-router)#network 10.1.1.0 0.0.0.255
BRANCH-1(config-router)#network 193.10.26.0 0.0.0.255
*Nov  5 11:33:47.726: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 193.10.26.1 (Serial1/0.2) is up: new adjacency
BRANCH-1(config-router)#network 193.10.25.0 0.0.0.255

BRANCH-2(config)#router eigrp 15
BRANCH-2(config-router)#network 10.1.2.0 0.0.0.255
BRANCH-2(config-router)#network 193.10.25.0 0.0.0.255
BRANCH-2(config-router)#network 193.10.26.0 0.0.0.255
*Nov  5 11:35:23.646: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 193.10.26.1 (Serial1/0.2) is up: new adjacency

BRANCH-3(config)#router eigrp 15
BRANCH-3(config-router)#network 10.1.3.0 0.0.0.255
BRANCH-3(config-router)#network 193.10.24.0 0.0.0.3
*Nov  5 11:36:49.987: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 193.10.24.1 (Serial1/0.1) is up: new adjacency
BRANCH-3(config-router)#network 193.10.24.4 0.0.0.3
*Nov  5 11:37:05.045: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 193.10.24.5 (Serial1/0.2) is up: new adjacency

2) Verify neighbors adjencencies on all routers
     * Branch1/2/3 should have Wan1/2 as neighbors
     * Wan1 should have Branch1, Branch2, Branch3, Wan2, Core 1 and Core 2
     * Wan2 should have Branch1, Branch2, Branch3, Wan1, Core 1 and Core 2
     * Core1 should have Wan1, Wan2 and Core 2
     * Core2 should have Wan1, Wan2 and Core 1


a) Branch1/2/3 should have Wan1/2 as neighbors
BRANCH-2#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(15)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   193.10.25.1             Se1/0.1                 156 00:03:10   16   100  0  26
0   193.10.26.1             Se1/0.2                 160 00:18:39  813  4878  0  28

b) Wan1 should have Branch1, Branch2, Branch3, Wan2, Core 1 and Core 2
WAN1#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(15)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
5   193.10.25.20            Se1/0.1                  14 00:00:09 1002  5000  0  9   Branch2
4   193.10.25.10            Se1/0.1                  10 00:00:09   19   114  0  12  Branch1
3   10.0.0.2                Et0/0                    14 00:03:47    9   100  0  14  Core2
2   10.0.0.20               Et0/0                    11 00:03:47    8   100  0  27  Wan2
1   10.0.0.1                Et0/0                    10 00:03:47    8   100  0  14  Core1
0   193.10.24.2             Se1/0.2                  13 00:14:12   20   120  0  13  Branch3

b) Core1 should have Wan1, Wan2 and Core 2
Core1#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(15)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
2   10.0.0.10               Et0/0                    11 00:08:49    1   100  0  28  Wan1
1   10.0.0.20               Et0/0                    14 00:26:15    3   100  0  27  Wan2
0   10.0.0.2                Et0/0                    14 00:27:29    4   100  0  14  Core2

3) Take a look at Branch/Wan/Core routing tables. A lot of route are missing. 
      * Branch routers don't know routes for each other nor for Core LAN.
      * Wan and Core routers don't know routes for Branch1/2/3 LAN
     Correct those issues. (hint: something should be done on routers situated between two classfull networks)
     Core1/2 and Wan1/2 should now know routes to all subnets. If any summary still appear in a rounting table... then you forgot to correct at least one router.

Note: auto-summary in EIGRP
From IOS version 12.2(33)SXI4 and 15.0, this command was modified. Address-family topology configuration mode was added.
The default behavior was changed to disabled.


Core1#sh ip route 10.1.2.1
% Subnet not in table

Core1#sh ip route
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/24 is directly connected, Ethernet0/0
L        10.0.0.1/32 is directly connected, Ethernet0/0
D     193.10.24.0/24 [90/2195456] via 10.0.0.20, 00:00:40, Ethernet0/0
                     [90/2195456] via 10.0.0.10, 00:00:40, Ethernet0/0
D     193.10.25.0/24 [90/2195456] via 10.0.0.10, 00:15:35, Ethernet0/0
D     193.10.26.0/24 [90/2195456] via 10.0.0.20, 00:15:35, Ethernet0/0

To resolve this task configure on all routers:
router eigrp 15
no auto-summary
Check
Core2#sh ip route
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.0.0.0/24 is directly connected, Ethernet0/0
L        10.0.0.2/32 is directly connected, Ethernet0/0
D        10.1.2.0/24 [90/2323456] via 10.0.0.20, 00:00:42, Ethernet0/0 Branch
                     [90/2323456] via 10.0.0.10, 00:00:42, Ethernet0/0 Branch
D        10.1.3.0/24 [90/2323456] via 10.0.0.20, 00:00:40, Ethernet0/0 Branch
                     [90/2323456] via 10.0.0.10, 00:00:40, Ethernet0/0 Branch
      193.10.24.0/30 is subnetted, 2 subnets
D        193.10.24.0 [90/2195456] via 10.0.0.10, 00:00:21, Ethernet0/0
D        193.10.24.4 [90/2195456] via 10.0.0.20, 00:00:19, Ethernet0/0
D     193.10.25.0/24 [90/2195456] via 10.0.0.10, 00:39:33, Ethernet0/0
D     193.10.26.0/24 [90/2195456] via 10.0.0.20, 00:39:33, Ethernet0/0

continue to part 2