CCNP ROUTE - OSPF part 3 (Network type/Frame-Relay)

To provide efficient IP multicast support in Frame Relay networks, the underlying Frame Relay network architecture should be designed in a "hub and spoke" topology (hierarchical topology).
The hub and spoke topology is also named a "star" topology, because the central hub acts as the center of a star and the connections to the remote sites act as light radiating from the star.

The word "broadcast",  much like in Ethernet MAC marking, indicates multicast packets as well.
Router must craft and transmit an individual packet for every destination he wants to reach.
Aside from being horribly inefficient with regard to bandwidth, this limitation requires the router to know the addresses of his neighbors before he can communicate to them.

OSPF can operate in one of two modes across a non-broadcast network: non-broadcast multi-access (NBMA) or point-to-multipoint.
Each of these topologies tackles the absence of broadcast capability from a different direction.

Clear explanation of network types

OSPF over Multipoint Frame Relay
To form OSPF neighbor relationships on LANs and point-to-point WAN interfaces, OSPF simply needs to be enabled on the interface, and the neighboring routers must agree to a set of parameters.
However, when using Frame Relay in certain configurations, engineers must do more implementation planning and use additional configuration commands to make OSPF work.

IP Subnetting Design over Frame Relay
When planning the subnets to use over a Frame Relay WAN:
1) single-subnet for all PVCs (full mesh, one /29  contains 6 usable IPs)
 with all routers using point-to-point subinterfaces associated with each single PVC (most used)
2) one-subnet-per-PVC  (partial full mesh,  using /30 per PVC)
many companies use private IP addresses inside their Enterprise internetwork (shortage of IP addresses). Not all routers can ping each other.

IOS enables Frame Relay Inverse ARP (InARP) by default, so all four routers learn of the other routers IP address/DLCI mappings dynamically.

Sample Configuration Using Physical Interfaces
! Router R1
interface S0/0/0
encapsulation frame-relay
ip address
! Router R2
interface S0/0/0
encapsulation frame-relay
ip address

Sample Configuration Using Multipoint Subinterfaces
When using subinterfaces, IOS needs a command under a Frame Relay subinterface that associates each PVC with that subinterface:  
frame-relay interface-dlci  or  frame-relay map
 - frame-relay interface-dlci - associates the DLCI with the subinterface, relying on Frame Relay InARP to discover mappings.
 - frame-relay map - statically configures that mapping, while also associating the DLCI with the subinterface.
! Router R1
interface S0/0/0
encapsulation frame-relay
interface S0/0/0.1 multipoint
ip address
frame-relay interface-dlci 102
frame-relay interface-dlci 103
frame-relay interface-dlci 104

OSPF Challenges When Using Multipoint
When OSPF is enabled on the interfaces, but do not add OSPF configuration, OSPF does not form neighborships in either case.
The default OSPF network type on multipoint interfaces–the nonbroadcast network type–prevents OSPF from working without further configuration.
An engineer needs to know the answer to three questions related to OSPF over Frame Relay multipoint interfaces:
■ Do the routers attempt to discover neighbors by sending and receiving multicast OSPF Hello messages, or do the neighbors require static definition?
■ Do the routers attempt to elect a DR/BDR?
■ Does a partial mesh exist or full mesh?

Neighbor Discovery or Static Neighbor Definition
The OSPF network type–a per-interface setting–defines whether a router attempts to discover OSPF neighbors on an interface.
When the router attempts discovery, it sends multicast ( OSPF Hello messages out the interface.

Multicast problem
Cause the dynamic OSPF neighbor discovery process to fail.
When a router needs to send a broadcast or multicast over Frame Relay, the router must actually send a copy of the packet over each PVC instead, because the Frame Relay network does not have the ability to replicate the broadcast or multicast packet. 

Routers do send the multicast OSPF Hellos for any PVCs listed in frame-relay interface-dlci commands, and for any DLCIs listed in framerelay map commands if the broadcast keyword was included.

Statically configured neighbors
Overcomes the issue with neighbor discovery.
neighbor <ip-address>
The actions to take for the issues related to neighbor discover:
■ If the configured network type allows for neighbor discovery using Hellos, and you use InARP, the neighbors should be discovered.
■ If the configured network type allows for neighbor discovery, and you use frame-relay map, ensure that the broadcast keyword is included.
■ If the configured network type does not allow for neighbor discovery, statically configure neighbors.

DR over Frame Relay
When a DR exists, all OSPF routers must send and receive OSPF messages with the DR, with messages to the DR being sent to the all-DR’s multicast address.
Additionally, the DR sends messages to the all-SPF router’s multicast address, with these messages intended for all OSPF routers in the subnet.
Two DROther routers do not need to send each other OSPF messages.
The following PVCs must exist:
■ Between the DR and every other router in the subnet
■ Between the BDR and every other router in the subnet

- If using a network type that requires a DR/BDR, restrict the role of DR and BDR to routers that have a PVC connecting to all other routers.
- Configure the OSPF network type to avoid using a DR/BDR.

Mapping Issues with a Partial Mesh
Relates to the Layer 2 mapping, either created by InARP or statically configured (frame-relay map).
This mapping on a router lists each neighbor’s IP address, and that router’s DLCI used to reach that router.

When OSPF works over this Frame Relay WAN, the next-hop address of the learned routes will list the IP address of a router in that WAN subnet–even if no PVC connects to that next-hop router.

To reach network from R2, on R2 and R1 are created static DLCI mapping
Solution: static mapping to correct exit DLCI  to reach the nexthop.

For any routers without a direct PVC, statically configure a IP-address-to-DLCI mapping with the other router’s next-hop IP address, and a DLCI that does connect to a router that has PVCs with each of the two routers

Configuring and Verifying OSPF Operations on Frame Relay
 - configure Frame Relay to use either physical interfaces or multipoint subinterfaces,
 - routers try and elect a DR, and will they try to discover neighbors.

OSPF works with IP protocol 89 and it uses two different multicast addresses with different purposes.
OSPF elects Designated Router (DR), and Backup Designated Router (BDR), their function is to change link-state LSAs with the DROTHER (all spf routers), and each DROTHER, communicates exclusively with the DR or in the case of a DR failure, the BDR takes its place. These communications are made through multicast in this manner:
 - All SPF routers multicast to address (DR),
 - DR communicates with all SPF routers (or with a single router), to mcast address

Network type is per interface settings
R(config-interface)#  ip ospf network <type>
RFC: OSPF can run over non-broadcast networks in one of two modes: NBMA or Point-to-MultiPoint: 
1) called NBMA (non-broadcast multi-access) - simulates the operation of OSPF on a broadcast network.
2) called Point-to-MultiPoint, treats the nonbroadcast network as a collection of point-to-point links.

Non-broadcast networks are referred to as NBMA networks or Point-to-MultiPoint networks, depending on OSPF’s mode of operation over the network.

Cisco have 5 different network types for NBMA networks:
1) broadcast (Cisco mode)
2) non-broadcast (RFC compliant mode)
3) point-to-multipoint (RFC compliant mode)
4) point-to-multipoint non-broadcast (Cisco mode)
5) point-to-point (Cisco mode)

nonbroadcast - disable broadcast (and multicast) on this interface, so manual neighbors must be defined

Multiaccess networks (Ethernet, Frame-relay) will use DR/BDR election.
Point-to-smthg will not.

Frame-Relay as NMBA will have "ip ospf network nonbroadcast" set by default.


Frame-relay from CCNA

1) Network Type Nonbroadcast (NBMA)
All routers need mapping to the other router’s IP addresses in their common Frame Relay subnet.
In this particular case, R1 learns all the mappings with InARP, because it has a PVC connected to all the other routers. However, R2, R3, and R4 have learned all OSPF routes but cannot forward traffic to each other because they have not learned the mappings.

NBMA use DR/BDR but with manual configuration of each OSPF neighbor (auto discovery not working because of multicast lack):
R(config-router)#  neighbor <next-hop-IP> [cost cost-value] [priority priority-value]
  * the higher number (ranges from 0–255) wins.
  * priority of 0 has special meaning: it prevents that router from becoming the DR/BDR
R# show running-config | begin router ospf
R# show ip ospf interface
R# show ip route ospf
R# show frame-relay map
Lab @

2) Network Type Point-to-Multipoint

Network type point-to-multipoint tells routers to act oppositely compared to the nonbroadcast type: to not elect a DR/BDR and to dynamically discover neighbors.

The only configuration requirement, beyond enabling OSPF on the multipoint subinterface or physical serial interface, is to configure any static Frame Relay mappings if a partial mesh exists.

If you are using a multipoint subinterface, you will need to configure frame-relay maps and you cannot rely on inverse-arp.
If you are using a point-to-point subinterface, you will need to assign a DLCI to the subinterface. 
interface Serial0/0/0.1 multipoint
  ip address
  frame-relay interface-dlci 102
  frame-relay interface-dlci 103
  frame-relay interface-dlci 104
  ip ospf network point-to-multipoint

3) Network Type Point-to-Multipoint Nonbroadcast

OSPF network type point-to-multipoint nonbroadcast tells routers to act like point-to-multipoint type by not electing a DR/BDR. However, the difference lies in neighbor discovery–the keyword “nonbroadcast” implies that the routers cannot broadcast (or multicast) to discover neighbors.

The configuration uses a mix of the commands seen for the nonbroadcast and point-to-multipoint network types:
 - no DR/BDR will be elected (ip ospf priority 0 command not needed)
 - neighbor commands needed to predefine neighbors
 - Frame Relay mapping must be added for those routers without direct PVCs.

This particular OSPF network type does have some design advantages if the design also uses multipoint subinterfaces. 
R1 (which have PVC to all routers)
interface Serial0/0/0.1 multipoint
ip address
frame-relay interface-dlci 102
frame-relay interface-dlci 103
frame-relay interface-dlci 104
ip ospf network point-to-multipoint non-broadcast
R2 (wich needed FR static mapping)
interface Serial0/0/0.1 multipoint
ip address
frame-relay interface-dlci 101
frame-relay map ip 101 broadcast
frame-relay map ip 101 broadcast
ip ospf network point-to-multipoint non-broadcast

OSPF Network Types