CCNA Commands

Convention

encapsulation frame-relay [cisco | ietf] - "cisco" from options is default
<>  - mandatory, are values (user indicated)

[]  - optional
{}  - required

|  - alternative 

TOC
1) Operating Cisco Router
2) Routing Protocol Concepts and Configuration
3) IP Routing: Static and Connected Routes
4) WAN Configuration
5) WAN Configuratio: PPP
6) WAN Configuration: Frame-Relay
7) NAT
8) IPv6
9) Ethernet Switch Configuration
10) VTP, VLAN, DTP, CDP
11) STP
12) Standart ACL
13) Advanced ACL
14) OSPF
15) EIGRP



Commands

1) Operating Cisco Router
___Configuration Command___
bandwidth <kbps>
! Interface command that sets the router’s perception of bandwidth of the interface, in a unit of kbps.

clock rate <rate>
! Interface command that sets the speed at which the router supplies a clocking signal, applicable only when the router has a DCE cable installed. The unit is bits/second.

config-register <value>
!  Global command that sets the hexadecimal value of the configuration register.

boot system {file-url | filename}
! Global command that identifies an externally located IOS image using a URL.

boot system flash [fiash-fs:] [filename]
! Global command that identifies the location of an IOS image in Flash memory.

boot system rom
! Global command that tells the router to load the RxBoot OS found in ROM, if one exists.

boot system {rcp | tftp | ftp} filename [ip-address]
! Global command that identifies an external server, protocol, and filename to use to load an IOS from an external server.

___EXEC Commands___

show interfaces [type number]
! Lists a large set of informational messages about each interface, or about the one specifically listed interface.

show ip interface brief
! Lists a single line of information about each interface, including the IP address, line and protocol status, and the method with which the address was configured (manual or DHCP).

show protocols <type> <number>
! Lists a single line of information about the listed interface, including the IP address, mask, and line/protocol status.

show controllers [type number]
! Lists many lines of information per interface, or for one interface, for the hardware controller of the interface. On serial interfaces, this command identifies the cable as either a DCE or DTE cable.

show version
! Lists the IOS version, as well as a large set of other useful information

setup
! Starts the setup (initial configuration) dialog in which the router prompts the user for basic configuration settings.

copy <source-url> <destination-url>
! Copies a file from the first listed URL to the destination URL.

show flash
! Lists the names and size of the files in Flash memory, as well as noting the amount of Flash memory consumed and available.

reload
! Enable mode command that reinitializes (reboots) the router.

show sessions
! Information about Telnet/ssh connections from your router (to other devices)

show users
! shows telnet/ssh connections to your router

2) Routing Protocol Concepts and Configuration
___Configuration Command___
router rip
! Global command that moves the user into RIP configuration mode.

network <network-number>
! RIP subcommand that lists a classful network number, enabling RIP on all of that router’s interfaces in that classful network.

version {1 | 2}
! RIP subcommand that sets the RIP version.

passive-interface [default] {interface-type interface-number}
! RIP subcommand that tells RIP to no longer advertise RIP updates on the listed interface.

ip address <ip-address> <mask>
! Interface subcommand that sets the router’s interface IP address and mask.

ip route <prefix> mask {ip-address | interface-type interface-number}
! Global command that defines a static route.

service timestamps
! Global command that tells the router to put a timestamp on log messages, including debug messages.
___EXEC Commands___
show ip interface brief
! Lists one line per router interface, including the IP address and interface status; an interface must have an IP address, and be in an “up and up” status, before RIP begins to work on the interface.

show ip route [rip | static | connected | ospf | ...]
! Lists the routing table, including RIP-learned routes, and optionally just RIP-learned routes.

show ip route <ip-address>
! Lists details about the route the router would match for a packet sent to the listed IP address.

show ip protocols
! Lists information about the RIP configuration, plus the IP addresses of neighboring RIP routers from which the local router has learned routes.

show process
! Lists information about the various processes running in IOS, and most importantly, overall CPU utilization statistics.

terminal ip netmask-format decimal
! For the length of the user’s session, causes IOS to display mask information in dotted-decimal format instead of prefix format.

debug ip rip
! Tells the router to generate detailed messages for each sent and received RIP update.

3) IP Routing: Static and Connected Routes
___Configuration Command___
encapsulation dot1q <vlan-id> [native]
! A subinterface subcommand that tells the router to use 802.1Q trunking, for a particular VLAN, and with the native keyword, to not encapsulate in a trunking header

encapsulation isl <vlan-identifier>
! A subinterface subcommand that tells the router to use ISL trunking for a particular VLAN

[no] ip classless
! Global command that enables (ip classless) or disables (no ip classless) classless routing

[no] ip subnet-zero
! Global command that allows (ip subnet-zero) or disallows (no ip subnet-zero) the configuration of an interface IP address in a zero subnet

ip address <ip-address> <mask> [secondary]
! Interface subcommand that assigns the interface’s IP address and optionally makes the address a secondary address

ip route <prefix> <mask> {ip-address | interface-type interface-number} [distance] [permanent]
! Global configuration command that creates a static route

ip default-network <network-number>
! Global command that creates a default route based on the router’s route to reach the classful network listed in the command

___EXEC Commands___

show ip route
!  Lists the router’s entire routing table

show ip route <ip-address>
! Lists detailed information about the route that a router matches for the listed IP address

ping {host-name | ip-address}
! Tests IP routes by sending an ICMP packet to the destination host

traceroute {host-name | ip-address}
! Tests IP routes by discovering the IP addresses of the routes between a router and the listed destination
 
4) WAN Configuration

___Configuration Command___
encapsulation {hdlc | ppp | frame-relay}
! Serial interface subcommand that de?nes the data-link protocol to use on the link

clock rate <speed>
! Serial interface subcommand that, when used on an interface with a DCE cable, sets the clock speed in bps

bandwidth <speed-kbps>
! Interface subcommand that sets the router’s opinion of the link speed, in kbps, but has no effect on the actual speed

description <text>
! Interface subcommand that can set a text description of the interface
___EXEC Commands___
show ip nat translations
! Lists the NAT/PAT translation table entries

show dhcp server
! Lists information learned from a DHCP server, by a router acting as a DHCP client

clear ip nat translation *
! Clears (removes) all dynamic entries in the NAT table

show interfaces
! Lists several important settings on serial links, including encapsulation, bandwidth, keepalives, the two status codes, description, and IP address/mask

show controllers serial <number>
! Lists whether a cable is connected to the interface, and if so, whether it is a DTE or DCE cable

show interfaces [type number] description
! Lists a single line per interface (or if the interface is included, just one line of output total) that lists the interface status and description
5) WAN Configuratio: PPP
___Configuration Command___
encapsulation {hdlc | ppp}
! Interface subcommand that defines the serial data-link protocol

ppp authentication {pap | chap | pap chap | chap pap}
! Interface subcommand that enables only PAP, only CHAP, or both (order-dependent)

username <name> password <secret>
! Global command that sets the password that this router expects to use when authenticating the router with the listed hostname
___EXEC Commands___
show interfaces [type number]
! Lists statistics and details of interface configuration, including the encapsulation type

debug ppp authentication
! Generates messages for each step in the PAP or CHAP authentication process

debug ppp negotiation
! Generates debug messages for the LCP and NCP negotiation messages sent between the devices

6) WAN Configuration: Frame-Relay 
___Configuration Command___
encapsulation frame-relay [cisco | ietf]
! Interface configuration command that defines the Frame Relay encapsulation that is used rather than HDLC, PPP, and so on

frame-relay lmi-type {ansi | q933a | cisco}
! Interface configuration mode command that defines the type of LMI messages sent to the switch

bandwidth <num>
! Interface subcommand that sets the router’s perceived interface speed

frame-relay map {protocol protocol-address dlci} [broadcast] [ietf | cisco]
! Interface configuration mode command that statically defines a mapping between a network layer address and a DLCI
When the “broadcast” keyword is included, it turns Frame Relay network as a broadcast network, which can forward broadcasts

keepalive <sec>
! Interface configuration mode command that defines whether and how often LMI status inquiry messages are sent and expected

interface serial <number.sub> [point-to-point | multipoint]
! Global configuration mode command that creates a subinterface or references a previously created subinterface

frame-relay interface-dlci dlci [ietf | cisco]
! Subinterface configuration mode command that links or correlates a DLCI to the subinterface
___EXEC Commands___
show interfaces [type number]
! Shows the physical interface status

show frame-relay pvc [interface interface][dlci]PVC Statistics for interface Serial0 (Frame Relay DTE)
DLCI = 666, DLCI USAGE = UNUSED, PVC STATUS = DELETED, INTERFACE = Serial0

! This command shows the status of the permanent virtual circuit (PVC), packets in and out, dropped packets if there is congestion on the line via forward explicit congestion notification (FECN) and backward explicit congestion notification (BECN), and so on.
The DLCI USAGE field contains one of the following entries:
    SWITCHED - the router or access server is used as a switch.
    LOCAL - the router or access server is used as data terminal equipment (DTE).
    UNUSED - the data-link connection identifier (DLCI) is not referenced by user-entered configuration commands on the router.

The PVC can have four possible states. These are shown by the PVC STATUS field as follows:
    ACTIVE - PVC is up and functioning normally.
    INACTIVE - PVC is not up end-to-end. This may be because either there is no mapping (or incorrect mapping) for the local DLCI in the frame-relay cloud or the remote end of the PVC is Deleted.
    DELETED - Either the Local Management Interface (LMI) is not exchanged between the router and the local switch, or the switch does not have DLCI configured on the local switch.
    STATIC - no keepalive configured on the frame-relay interface of the router.

show frame-relay lmi [type number]
! This command is used to verify some LMI statistics in the output, look for any non-zero "Invalid" items

show frame-relay map
- Serial0/0/0 (up): ip 10.1.1.2 dlci 102 (0x66, 0x1860), static, broadcast, CISCO, status defined, active
- (or) Serial0 (up): ip 157.147.3.65 dlci 980(0x3D4,0xF440), dynamic, broadcast,, status defined, active
! Display the current map entries and information about the connections.    
Verify whether the frame-relay inverse-arp command resolved a remote IP address to a local DLCI.
    10.1.1.2 is the IP address of the remote router, dynamically learned via the Inverse ARP process.
    102 is the decimal value of the local DLCI number.
    0x66 is the hex conversion of the DLCI number, 0x66 = 102 decimal.
    0x1860 is the value, as it would appear on the wire because of the way the DLCI bits are spread out in the address field of the Frame Relay frame.
    Broadcast/multicast is enabled on the PVC.
    dynamic - DLCI was learned through Inverse ARP
    PVC status is active.

debug frame-relay lmi        Displays the contents of LMI messages
debug frame-relay events     Lists messages about certain Frame Relay events, including Inverse ARP messages

7) NAT
___Configuration Command___
ip nat {inside | outside}
! Interface subcommand to enable NAT and identify whether the interface is in the inside or outside of the network

ip nat inside source {list {access-list-number | access-list-name}} {interface type number | pool pool-name}[overload]
! Global command that enables NAT globally, referencing the ACL that defines which source addresses to NAT, and the interface or pool from which to find global addresses

ip nat <pool name> <start-ip> <end-ip> {netmask <netmask> | prefix-length <prefix-length>}
! Global command to define a pool of NAT addresses

ip nat source static inside-ip {outside-ip | interface-id}
! Global command that lists the inside and outside address (or, an outside interface whose IP address should be used) to be paired and added to the NAT translation table
___EXEC Commands___
show ip nat statistics
! Lists counters for packets and NAT table entries, as well as basic configuration information

show ip nat translations [verbose]
! Displays the NAT table

clear ip nat translation {* | [inside <global-ip> <local-ip>] [outside <local-ip> <global-ip>]}
! Clears all or some of the dynamic entries in the NAT table, depending on which parameters are used

clear ip nat translation <protocol> inside <global-ip> <global-port> <local-ip> <local-port> [outside <local-ip> <global-ip>]
! Clears some of the dynamic entries in the NAT table, depending on which parameters are used

debug ip nat
! Issues a log message describing each packet whose IP address is translated with NAT

8) IPv6
___Configuration Command___
ipv6 unicast-routing
! Global command that enables IPv6 routing on the router

ipv6 router rip <tag>
! Global command that enables RIPng

ipv6 rip <name> enable
! Interface subcommand that enables RIPng on the interface

ipv6 address {<ipv6-address>/<prefix-length> | <prefix-name> <sub-bits>/<prefix-length>} eui-64
! Interface subcommand that manually configures either the entire interface IP address, or a /64 prefix with the router building the EUI-64 format interface ID automatically

ipv6 host <name> <ipv6-address1> [ipv6-address2...ipv6-address4]
! Global command to create a static host name definition

ip name-server <name-server-address1> [server-address2...server-address6]
! Global command to point to one or more name servers, to resolve a name into either an IPv4 or IPv6 address

[no] ip domain-lookup
! Global command that enables the router as a DNS client, or with the no option, disables the router as a DNS client
___EXEC Commands___
show ipv6 route
! Lists IPv6 routes

show ipv6 route <ipv6-address>
! Lists the route(s) this router would match for packets sent to the listed address

show ipv6 route [prefix/prefix-length]
! Lists the route for the specifically listed prefix/length

show ipv6 interface [type number]
! Lists IPv6 settings on an interface, including link local and other unicast IP addresses

show ipv6 interface brief
! Lists interface status and IPv6 addresses for each interface

9) Ethernet Switch Configuration
___Configuration Command___
_Basic Password Configuration_
line console 0
! Changes the context to console configuration mode.

line vty <1st-vty> <2nd-vty>
! Changes the context to vty configuration mode for the range of vty lines listed in the command.

login
! Console and vty configuration mode. Tells IOS to prompt for password.

password <pass-value>
! Console and vty configuration mode. The password required if the login command (with no other parameters) is configured.
_Username/Password and SSH Configuration_
login local
! Console and vty configuration mode. Tells IOS to prompt for a username and password, to be checked against locally configured username global configuration commands on this switch or router.

username <name> password <pass-value>
! Global command. Defines one of possibly multiple usernames and associated passwords, used for user authentication. Used when the login local line configuration command has been used.

crypto key generate rsa
! Global command. Creates and stores (in a hidden location in fiash memory) the keys required by SSH.

transport input {telnet | ssh}
! vty line configuration mode. Defines whether Telnet and/or SSH access is allowed into this switch
! The default is transpot input telnet , ommiting the ssh parameter
_IP Address Configuration_
interface vlan <number>
! Global command. Changes the context to VLAN interface mode. For VLAN 1, allows the configuration of the switch’s IP address.

ip address <ip-address> <subnet-mask>
! VLAN interface mode. Statically configures the switch’s IP address and mask.

ip address dhcp
! VLAN interface mode. Configures the switch as a DHCP client to discover its IP address, mask, and default gateway.

ip default-gateway <address-of-nexthop>
! Global command. Configures the switch’s default gateway IP address. Not required if the switch uses DHCP.
_Interface Configuration_
interface <type> <port-number>
! Changes context to interface mode. The type is typically FastEthernet or gigabitEthernet.
! The possible port numbers vary depending on the model of switch—for example, Fa0/1, Fa0/2, and so on.

interface range <type> <port-range>
! Changes the context to interface mode for a range of consecutively numbered interfaces.
! The subcommands that follow then apply to all interfaces in the range.

shutdown
no shutdown
! Interface mode. Disables or enables the interface, respectively.

speed {10 | 100 | 1000 | auto}
! Interface mode. Manually sets the speed to the listed speed or, with the auto setting, automatically negotiates the speed.

duplex {auto | full | half}
!  Interface mode. Manually sets the duplex to half or full, or to autonegotiate the duplex setting.

description <text>
! Interface mode. Description, place.
_Miscellaneous_
hostname <name>
! Global command. Sets this switch’s hostname, which is also used as the first part of the switch’s command prompt.

enable secret <pass-value>
! Global command. Sets this switch’s password that is required for any user to reach _enable_ mode.

history size <length>
! Line config mode. Defines the number of commands held in the history buffer, for later recall, for users of those lines.

switchport port-security mac-address <mac-address>
! Interface configuration mode command that statically adds a specific MAC address as an allowed MAC address on the interface.

switchport port-security mac-address sticky
! Interface subcommand that tells the switch to learn MAC addresses on the interface and add them to the configuration for the interface as secure MAC addresses.

switchport port-security maximum <value>
! Interface subcommand that sets the maximum number of static secure MAC addresses that can be assigned to a single
interface.

switchport port-security violation {protect | restrict | shutdown}
! Interface subcommand that tells the switch what to do if an inappropriate MAC address tries to access the network through a secure switch port.
! protect - discard traffic, no log, no disable interface
! restrict - discard traffic, log, no disable interface
! shutdown - discard traffic, log, disable interface

arp 1.2.3.4 AAAA.BBBB.DDDD arpa
! Global. Configure a static ARP entry for the mac address of AAAA.BBBB.DDDD for IP 1.2.3.4

___EXEC Commands___
show mac address-table dynamic
! Lists the dynamically learned entries in the switch’s address (forwarding) table.

show dhcp lease
! Lists any information the switch acquires as a DHCP client. This includes IP address, subnet mask, and default gateway information.

show crypto key mypubkey rsa
! Lists the public and shared key created for use with SSH using the crypto key generate rsa global configuration command.

show interfaces status
! Lists one output line per interface, noting the description, operating state, and settings for duplex and speed on each interface.

show interfaces vlan 1
! Lists the interface status, the switch’s IP address and mask, and much more.

show port-security interface <type> <number>
! Lists an interface’s port security configuration settings and security operational status.

show arp
!

10) VTP, VLAN, DTP, CDP
___Configuration Command___
vlan vlan-id
! Global config command that both creates the VLAN and puts the CLI into VLAN configuration mode

name vlan-name
! VLAN subcommand that names the VLAN

shutdown
! VLAN subcommand that prevents that one switch from forwarding traffic in that VLAN

shutdown vlan vlan-id
! Global config command that administratively disables a VLAN, preventing the switch from forwarding frames in that VLAN

vtp domain domain-name
! Global config command that defines the VTP domain name

vtp password password
! Global config command that defines the VTP password

vtp mode {server | client | transparent}
! Global config command that defines the VTP mode

vtp pruning
! Global config command that tells the VTP server to tell all switches to use VTP pruning

switchport mode {access | dynamic {auto | desirable} | trunk}
! Interface subcommand that configures the trunking administrative mode on the interface

switchport trunk allowed vlan {add | all | except | remove} vlan-list
! Interface subcommand that defines the list of allowed VLANs

switchport access vlan vlan-id
! Interface subcommand that statically configures the interface into that one VLAN

switchport trunk encapsulation {dot1q | isl| negotiate}
! Interface subcommand that defines which type of trunking to use, assuming that trunking is configured or negotiated

switchport voice vlan vlan-id
! Interface subcommand that defines the VLAN used for frames sent to and from a Cisco IP phone

switchport nonnegotiate
! Interface subcommand that disables the negotiation of VLAN trunking (DTP)

cdp run
! Global command. Enable CDP on device

no cdp run
! Global command. Disable CDP on device

cdp enable
! Interface command. Enable CDP on specific interface

___EXEC Command___
show interfaces interface-id switchport
! Lists information about any interface regarding administrative settings and operational state

show interfaces interface-id trunk
! Lists information about all operational trunks (but no other interfaces), including the list of VLANs that can be forwarded over the trunk

show vlan [brief | id <vlan-id> | name <vlan-name> | summary]
! Lists information about the VLAN

show vlan [vlan]
! Displays VLAN information

show vtp status
! Lists VTP configuration and status information

show vtp password
! Lists the VTP password

show cdp neighbors | interface | traffic
! CDP neighbor information by neighbors, interfaces, traffic

show cdp neighbors
detail
! Show detailed information

show cdp entry <device-ID>
! Show CDP info for Device-ID from show cdp neighbor

11) STP
___Configuration Command Reference___
spanning-tree mode {mst | rapid-pvst | pvst}
! Global command to enable PVST+ and 802.1d (pvst),PVRST and 802.1w (rapid-pvst), or IEEE 802.1s (multiple spanning trees) and 802.1w (mst).

spanning-tree vlan vlan-number root primary
! Global configuration command that changes this switch to the root switch.
! The switch’s priority is changed to the lower of either 24,576 or 4096 less than the priority of the current root bridge.

spanning-tree vlan vlan-number root secondary
! Global configuration command that sets this switch’s STP base priority to 28,672.

spanning-tree [vlan vlan-id] {priority priority}
! Global configuration command that changes the bridge priority of this switch for the specified VLAN.

spanning-tree [vlan vlan-number] cost cost
! Interface subcommand that changes the STP cost to the configured value.

channel-group channel-group-number mode {auto | desirable | on}
! Interface subcommand that enables EtherChannel on the interface.

spanning-tree portfast
! Interface subcommand that enables PortFast on the interface.

spanning-tree bpduguard enable
! Interface subcommand to enable BPDU Guard on an interface

___EXEC Command Reference___
show spanning-tree
! Lists details about the state of STP on the switch, including the state of each port.

show spanning-tree interface interface-id
! Lists STP information only for the speci?ed port.

show spanning-tree vlan vlan-id
! Lists STP information for the specified VLAN.

show spanning-tree [vlan vlan-id] root
! Lists information about each VLAN’s root or for just the specified VLAN.

show spanning-tree [vlan vlan-id] bridge
! Lists STP information about the local switch for each VLAN or for just the specified VLAN.

debug spanning-tree events
! Causes the switch to provide informational messages about changes in the STP topology.

show etherchannel [channel-group-number] {brief | detail | port | port-channel | summary}
! Lists information about the state of EtherChannels on this switch.

12) Standart ACL
___Configuration Command___
access-list <access-list-number> {deny | permit} <source> [source-wildcard] [log]
! Global command for standard numbered access lists. Use a number between 1 and 99 or 1300 and 1999, inclusive.

access-list <access-list-number> remark <text>
! Defines a remark that helps you remember what the ACL is supposed to do.

ip access-group {number | name [in | out]}
! Interface subcommand to enable access lists.
___EXEC Commands___
show ip <interface> [type number]
! Includes a reference to the access lists enabled on the interface.

show access-lists [access-list-number | access-list-name]
! Shows details of configured access lists for all protocols.

show ip access-list [access-list-number | access-list-name]
! Shows IP access lists.

13) Advanced ACL
___Configuration Command___
_Extended_
access-list <access-list-number> {deny | permit} <protocol> <source> <source-wildcard> <destination> <destination-wildcard> [log]
! Global command for extended numbered access lists. Use a number between 100 and 199 or 2000 and 2699, inclusive.

access-list <access-list-number> {deny | permit} tcp <source> <source-wildcard> [operator [port]] <destination> <destination-wildcard> [operator [port]] [log]
! A version of the access-list command with TCP-specific parameters.

access-list <access-list-number> remark <text>
! Defines a remark that helps you remember what the ACL is supposed to do.

ip access-group {number | name [in | out]}
! Interface subcommand to enable access lists
_Named_
access-class <number> | name [in | out]
! Line subcommand to enable either standard or extended access lists

ip access-list {standard | extended} <name>
! Global command to configure a named standard or extended ACL and enter ACL configuration mode

{deny | permit} <source> [source wildcard] [log]
! ACL mode subcommand to configure the matching details and action for a standard named ACL

{deny | permit} <protocol> <source> <source-wildcard> <destination> <destination-wildcard> [log]
! ACL mode subcommand to configure the matching details and action for an extended named ACL

{deny | permit} tcp <source> <source-wildcard> [operator [port]] <destination> <destination-wildcard> [operator [port]] [log]
! ACL mode subcommand to configure the matching details and action for a named ACL that matches TCP segments

remark <text>
! ACL mode subcommand to configure a description of a named ACL.
___EXEC Commands___
show ip interface [type number]
! Includes a reference to the access lists enabled on the interface.

show access-lists [access-list-number | access-list-name]
! Shows details of configured access lists for all protocols.

show ip access-list [access-list-number | access-list-name]
! Shows IP access lists.

14) OSPF
___Configuration Command___
router ospf <process-id>
! Enters OSPF configuration mode for the listed process

router-id <id>
! OSPF command that statically sets the router ID

network <ip-address> <wildcard-mask> area <area-id>
! Router subcommand that enables OSPF on interfaces matching the address/wildcard combination and sets the OSPF area

ip ospf cost <interface-cost>
! Interface subcommand that sets the OSPF cost associated with the interface

bandwidth <bandwidth>
! Interface subcommand that directly sets the interface bandwidth (Kbps)

auto-cost reference-bandwidth <number>
! Router subcommand that tells OSPF the numerator in the Ref-BW/Int-BW formula used to calculate the OSPF cost based on the interface bandwidth

ip ospf hello-interval <number>
! Interface subcommand that sets the OSPF Hello interval and also resets the Dead interval to 4 times this number

ip ospf dead-interval <number>
! Interface subcommand that sets the OSPF dead timer

ip ospf network <type>
! Interface subcommand that defines the OSPF network type

ip ospf hello-interval <seconds>
! Interface subcommand that sets the interval for periodic Hellos

ip ospf priority <number-value>
! Interface subcommand that sets the OSPF priority on an interface

maximum-paths <number-of-paths>
! Router subcommand that defines the maximum number of equal-cost routes that can be added to the routing table

ip ospf authentication [null | message-digest]
! Interface subcommand that enables type 0 (null), type 1 (no optional parameter listed), or type 2 (message-digest) authentication

ip ospf message-digest-key <key-number> md5 <key-value>
! Interface subcommand that sets the OSPF authentication key if MD5 authentication is used

ip ospf authentication <key-value>
! Interface subcommand that sets the OSPF authentication key if simple password authentication is used

area <area> authentication [message-digest | null]
! Router subcommand that configures the default authentication service for interfaces in the listed area
___EXEC Commands___
show ip route ospf       Lists routes in the routing table learned by OSPF
show ip protocols        Shows routing protocol parameters and current timer values
show ip ospf interface   Lists the area in which the interface resides, neighbors adjacent on this interface, and Hello and dead timers

show ip ospf neighbor [neighbor-RID]
! Lists neighbors and current status with neighbors, per interface, and optionally lists details for the router ID listed in the command

debug ip ospf events     Issues log messages for each OSPF packet.
debug ip ospf packet     Issues log messages describing the contents of all OSPF packets.
debug ip ospf hello      Issues log messages describing Hellos and Hello failures.

15) EIGRP
___Configuration Command___
router eigrp <autonomous-system>
! Global command to move the user into EIGRP configuration mode for the listed ASN

network network-number [wildcard-mask]
! EIGRP router subcommand that matches either all interfaces in a classful network, or a subset of interfaces based on the ACL-style wildcard mask, enabling EIGRP on those interfaces.

maximum-paths <number-paths>
! Router subcommand that defines the maximum number of equal-cost routes that can be added to the routing table

variance <multiplier>
! Router subcommand that defines an EIGRP multiplier used to determine if a feasible successor route’s metric is close enough to the successor’s metric to be considered equal

bandwidth <bandwidth>
! Interface subcommand directly sets the interface bandwidth (kbps)

delay <delay-value>
! Interface subcommand to set the interface delay value with a unit of tens-of-microseconds

ip hello-interval eigrp <as-number> <timer-value>
! Interface subcommand that sets the EIGRP Hello interval for that EIGRP process

ip hold-time eigrp <as-number> <timer-value>
! Interface subcommand that sets the EIGRP hold time for the interface

maximum-paths <number-of-paths>
! Router subcommand that defines the maximum number of equal-cost routes that can be added to the routing table

ip authentication key-chain eigrp <asn> <chain-name>
! Interface subcommand that references the key chain used for MD5 authentication with EIGRP

ip authentication mode eigrp <asn> md5
! Interface subcommand that enables EIGRP MD5 authentication for all neighbors reached on the interface

key chain <name>
! Global command to create and name an authentication key chain

key <integer-number>
! Key chain mode command to create a new key number.

key-string <text>
! Key chain mode command to create the authentication key’s value

accept-lifetime <start-time> {infinite | end-time | duration seconds}
! Key chain mode command to set the time frame during which a router will accept the use of a particular key

send-lifetime <start-time> {infinite | end-time | duration seconds}
! Key chain mode command to set the time frame during which a router will send EIGRP messages using a particular key

___EXEC Commands___
 show ip route eigrp
! Lists routes in the routing table learned by EIGRP

show ip route <ip-address> [mask]
! Shows the entire routing table or a subset if parameters are entered

show ip protocols
! Shows routing protocol parameters and current timer values

show ip eigrp neighbors
! Lists EIGRP neighbors and status

show ip eigrp topology
! Lists the contents of the EIGRP topology table, including successors and feasible successors

show ip eigrp traffic
! Lists statistics on the number of EIGRP messages sent and received by a router

debug eigrp packets
! Displays the contents of EIGRP packets

debug eigrp fsm
! Displays changes to the EIGRP successor and feasible successor routes

debug ip eigrp
! Displays similar output to the debug eigrp packets command but specifically for IP

1 comment :

  1. Hi Very good Blog and best posts,
    Please keep updating it..
    Cheers!!

    ReplyDelete